Image 01
profile-image

parasyte

Karl Redman Chicago, United States of America
usplash fingerprint-remix

Usplash Themes by parasyte 17 comments

sorry for the delay here -work stuff happened. Is this working for everyone now? - Apr 10 2008
usplash fingerprint-remix

Usplash Themes by parasyte 17 comments

frankly, very little.

This version is a complete rework of the original K environment stuff. I started from scratch and worked up to something that is very similar to what you mention. I worked out a text box area that is pretty (for me) but the original other one didn't work for me -this is fixed in his new implimentation.

The original project didn't work for my system so I went on to make my own. I think Embrace did an excellent job overall and I love his documentation (which is why I refer to it in my own notes here).

I added reverse animation for the top bar and a little extra color on the top few lines. Like I said, this was primarily for my own use but I thought I should at least share what I have. Embrace seems to be taking this much more seriously overall.

lol, but I'm still using my version even though the other original version is very cool :P

[Note: I did not start this project to compete with Embrace in the slightest. I only wanted to see how it worked and to make it work for my own system] - Jul 01 2007
Usplash Theme - Fingerprint

Usplash Themes by Embrace 198 comments

cool! I'll check it out later today. This inspired me to attempt to make one of these on my own as well. I learned that it isn't so easy..... :D

also, sorry about the duplicate post back there -it was a result of a refresh. - Jun 30 2007
Usplash Theme - Fingerprint

Usplash Themes by Embrace 198 comments

I see there are several posts about this black box issue and I had the same problem but found a solution that works for me on Ubuntu (Fiesty Fawn).

First off, be sure to have a correct "kernel" line in your menu.lst (from /boot/grub directory most likely). Mine looks like this:
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=b415c32e-f248-4b49-a225-94340f2cb8f6 ro quiet splash locale=en_US vga=791

Note that I'm using en_US for locale but your milage may very. Also note that the word 'quiet' is in there -otherwise usplash will expect a proper text area.

Having 'quiet' in the kernel line doesn't make the text box go away for me though. So on to the source code (file usplash-theme-ubuntu.c):

In the sources, change the color codes. I used the libusplash-dev example scheme for this. So in the structure usplash_theme_1024_768, for instance, I changed this:
/* Palette indexes */
/* parasyte - these colors are broken
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x0,
.text_foreground = 0x156,
.text_success = 0x15,
.text_failure = 0x144,
*/

to this:
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x31,
.text_foreground = 0x15,
.text_success = 0x171,
.text_failure = 0x156,

rebuilding the project and following the normal install procedures now works fine. I've also done some other customizations like moved the box over the text area and turned of quiet but that is info for another time.

-parasyte - Jun 30 2007
Usplash Theme - Fingerprint

Usplash Themes by Embrace 198 comments

I see there are several posts about this black box issue and I had the same problem but found a solution that works for me on Ubuntu (Fiesty Fawn).

First off, be sure to have a correct "kernel" line in your menu.lst (from /boot/grub directory most likely). Mine looks like this:
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=b415c32e-f248-4b49-a225-94340f2cb8f6 ro quiet splash locale=en_US vga=791

Note that I'm using en_US for locale but your milage may very. Also note that the word 'quiet' is in there -otherwise usplash will expect a proper text area.

Having 'quiet' in the kernel line doesn't make the text box go away for me though. So on to the source code (file usplash-theme-ubuntu.c):

In the sources, change the color codes. I used the libusplash-dev example scheme for this. So in the structure usplash_theme_1024_768, for instance, I changed this:
/* Palette indexes */
/* parasyte - these colors are broken
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x0,
.text_foreground = 0x156,
.text_success = 0x15,
.text_failure = 0x144,
*/

to this:
.background = 0x0,
.progressbar_background = 0x7,
.progressbar_foreground = 0x156,
.text_background = 0x31,
.text_foreground = 0x15,
.text_success = 0x171,
.text_failure = 0x156,

rebuilding the project and following the normal install procedures now works fine. I've also done some other customizations like moved the box over the text area and turned of quiet but that is info for another time.

-parasyte - Jun 29 2007