KrossWordPuzzle

Board by fpuelz 165 comments

Ok, I uploaded a "new version" with a corrected install file, so just download the new version ;)
I also checked the archive file, and there were indeed too many subfolders. More than I wanted Ark to pack.. So I used the tar shell command to compress it correctly. - Sep 09 2009
KrossWordPuzzle

Board by fpuelz 165 comments

Hi,
thanks for the info. That's because the egyptian theme was too big, to be uploaded here.. and I forgot to remove it from the install files. I will correct that in the next version.
For now you can remove the string "egyptian_theme.svgz" from the file "pics/CMakeLists.txt". It only contains one line:
install( FILES default_theme.svgz egyptian_theme.svgz scribble_theme.svgz DESTINATION ${DATA_INSTALL_DIR}/krosswordpuzzle/pics )

The open dialog uses MIME types as filter, so they need to be installed correctly. And the letters are also themed and themes are searched for in the install directory. So it's all because the egyptian theme was too big ;) Sorry.

The many subdirs were mostly created by the KDE App Template. But they help organizing the different files. - Sep 09 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

You're right, it was missing since version 0.5, where I introduced the accessor info xmls.. Sorry. I have now created an xml for vrn.de and will include it in the next version. - Aug 19 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I don't know if there is a slovak translation for publicTransport in KDEs SVN. And I changed/added many strings. So it would be great if you translate missing/changed strings (a link to the slovak translation team here: http://l10n.kde.org/team-infos.php?teamcode=sk).
Great that resizing is now working for you with KDE 4.3. - Aug 04 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The next version will include support for GetHotNewStuff and a button to install local files. They are installed with root privileges with use of kdesu for now. Maybe it's better to also have a user-specific directory. At least root privileges aren't needed then.
There is now a SVN repository for GHNS at newstuff.kde.org (thanks to Josef Spillner). Should be usable soon, after a bug has been fixed with the SVN repo. Thanks for the idea! There isn't much code needed to include GHNS support, great :) - Aug 03 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I just went through the comments, to mention closed bugs.
The items should now be more easily readable on themes like aya.
The city selections are now also remembered. - Aug 03 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Hm.. today I have only 1,500 pixmaps, X was running 18 hours. But I removed the second public transport applet.
Maybe something is fixed in plasma.. or it's only a problem with multiple public transport applets.. I don't know.
Maybe it's worse when "maximum departure count" is higher, I set it to 30. - Jul 30 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The icon in the panel won't get bigger than it is now. I think I only add some text like "10 min." and the vehicle type icon.

I can resize the applet freely.. I think it's because you're using KDE 4.2. But 4.3 will be out in some days and you will be able to resize it like you want (hopefully) :)

Translations can be done in KDE's SVN and is already (it's in playground). You can join the slovak translation team. I just don't know how to get the applet translated without compiling in SVN (and also haven't tried that ;)). - Jul 30 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I will make it configurable (when I find some time to implement it ;)). - Jul 30 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I can confirm it. I have two applets running and had 10,000 pixmaps. At start it's also under 1,000.
I'll try to find out what's causing this.
Thanks for the hint :) - Jul 29 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I don't know what's causing this. But I needed only one restart ;) When I look through the icons in dolphin the new icons are in there but they aren't displayed in the applet.
I'm loading the icons with the KIcon class, maybe someone has suggestions? - Jul 28 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Currently it only displays alarms on the icon, when it's in the panel (only if an alarm is set). I will add more information as suggested :)
With the vehicle type icon and the time till departure/arrival I think.

But you should be able to freely resize the applet (on desktop or when in the panel). I tested it and I can do so. Or did you mean something else? - Jul 28 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The DPI is no problem here, I have the same settings ;) The font was the problem. I changed the code so that more fonts look good in the applet. - Jul 28 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The rows should also be high enough for two lines per row.. Please tell me what plasma theme you are using (or what custom font you have selected). I will try to get it right then.
Hm.. I don't know if the font comes from KDE's global settings. So also tell me what font you use in systemsettings => appearance => fonts => desktop font. Thanks :) - Jul 27 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I finally fixed this bug.
First I added the "&rt=1" to the raw url of de_db. Then I did some testing, to see why the delay wasn't parsed correctly. After removing the comments in the xml it worked.. My xml-reading code isn't too good I think ;) (using QtXml). This will be in 0.5.4. - Jul 27 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The time edit control for a custom first departure is now enabled properly. Thanks for the hint!
I also fixed the delay parsing for de_db! More info on that as a reply to your other delay-comment.
Will be in version 0.5.4. - Jul 27 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Great to hear that it's working well :)
And yes, please make a screenshot. Or describe what glitches there are. - Jul 27 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Sorry, I already uploaded it again with the accessorInfos directory. I was sure that I added it...
Hopefully it doesn't crash anymore now. I noticed that it can crash, when there are no accessor infos. I will fix this for the next version. - Jul 27 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I maybe solved the problem with the wrong colors. The applet wasn't updating all colors, when the current theme was changed. But now it does. - Jul 27 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

It is displaying "Poland" because it's the english name of the country and all strings are in english unless they are translated.
Now it displays the translated country name in the location combobox, which should be "Lechia" for you? But the country name still isn't translated in the service provider combobox, because here it's the name of the service provider. I will change this to also use the translated country name here (if a country name is in the service provider name).
(I hope this wasn't confusing ;)) - Jul 27 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

On my openSuse system (with KDE 4.3 RC 2) there is no difference between publicTransport on the desktop and in the panel.. But on some (most?) light themes, the svg frame I'm using for the applet is missing, so it uses the one from oxygen. So the departure rows have a dark background and a dark text, because the text color comes from the light theme..
I will try to find a better svg, which works with all themes. Maybe I find out why there are differences between desktop and panel for you. - Jul 26 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Great to hear that your bus stop is supported! It was done with help from takanowaka :) (based on the cz_idnes-accessor info).
The problem with the city selection is a bug with finding the correct city in the list of cities.. I will fix it for the next version. Thanks for the hint.
For the Aya thing.. it seems that Aya doesn't have the svg I'm using, so it uses the oxygen one, which is black. Maybe I'm using a wrong svg. I will check it and have it hopefully fixed for the next version.
Please test the applet again with the next version (when I upload it.. will be soon). I want to get rid of all those bugs, the next versions will be bug fix releases. - Jul 25 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

CMakeLists.txt of the icons: sorry that it's missing. For now you can use the one of version 0.5.1. I will double check that it's included in 0.5.3.
I just fixed the issue with the vehicle types for imhd.sk and added/removed the lines you mentioned.
The bug with the city selection will be fixed in 0.5.3, I will do that tommorow.
Thanks for the bug reports! For the next versions I will focus more on bug fixing. So keep testing, the next version to be tested will be out soon :) - Jul 25 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

That was easy to fix :) Thanks for the hint! Will be in the next version. - Jul 25 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I checked it, and it's because the vehicle types are not always parsed correctly on sbb.ch. When an icon (e.g. for tram) is shown, it has been parsed and can be filtered.
I currently parse the vehicle type from the image-name that is shown in the html-results-page from sbb.ch. There are different names for the tram-icon and also for the bus-icon.. I added new names I found.
And in the next version I will parse the vehicle type from the image name and from the line name, e.g. "Tram 10". So the vehicle type parsing (and filtering) will get better :) - Jul 22 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Thanks :)

I fixed the autocompletion (one char was missing from the regExp.. it got lost, when I moved the accessor-infos from the code to the XML files)
The journey search is now also fixed (it didn't work for journeys with departure and arrival date being equal, I tested it with long journeys, so they weren't equal..)
And I added new vehicle types: metro, trolley bus, ferry and even plane (with data from flightstats.com), with icons (except for the trolley bus for now.. is there one?) Please give me a stop name, where trolley buses depart, so that I can test it. A stop where many postauto-buses depart would also be nice, to fix the problem with them.
I'll upload the next version soon.

Thanks again - Jul 20 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

One more comment ;) for the airport departures thing: I found flightstats.com to be a great data source. It works for all main airports :) around the world. So one accessor info xml is all that is needed to integrate aeroplane departures to the plasmoid. - Jul 18 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I wrote a simple accessor for www.airport-bremen.de, which has departure data for aeroplanes (for the whole day). Nice ;) Would be great to find a site for more airports. - Jul 18 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Great :) Maybe there are special sites for departures of planes. The plasmoid could need a new name then..

And sorry for confusing you ;) - Jul 18 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Ok, 4. is wrong.. You wrote cz_idnes but I tried to insert the cities into sk_imhd.. ;)
But "autobusy" still isn't a city. Or is it..? Also "vlaky" and "vlaky + autobusy". - Jul 18 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

1. Great :) I'll add the atlas-accessor-info-xml in the next version.
2. These xml files contain infos for the html- or xml-accessor. Just to clarify ;) So I think a good name for the files would be "accessor info xml".
3. I tested the new atlas-accessor-info with Bratislava, stop Hauerland. It works :) And it seems as it has some more departures than idnes.sk. I added stop autocompletion, tested it with some other cities and seems to work great :)
4. The new cities, you added to imhd doesn't seem to work here. ("Autobusy" isn't a city) The city replacement values for imhd have two chars (I think), like 'ba' for 'bratislava'. The other values inserted into the raw url always point to "http://imhd.zoznam.sk/ba/". I think imhd only supports the cities that are already in the xml? But it also only has data for bratislava somehow.. Maybe imhd can be removed?, atlas seems to be better :)
5. Thanks - Jul 18 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

I found out that I didn't remove the extra escapes (for C++) from the regular expressions for dvb.de. That is fixed in version 0.5.1 and now it works again :) (Tested with "Koblenzer Straße") - Jul 17 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Sorry. But there's now an xml file for Slovakia in version 0.5.1. - Jul 17 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Sorry. I don't know what's causing this.. Did it work in 0.4.8? And is it still working with 0.4.8? Maybe dvb.de changed something.
But you can use db.de, that works with "Dresden, Koblenzer Straße". The only bad thing here is that the target names are a bit longer, because ", Dresden" is appended to each target name (in Dresden). Are there other things why you don't want to use db.de? - Jul 17 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Hm, my plasma-desktop currently uses 52MB for everything including a publictransport-applet. I haven't noticed performance issues.
But I optimized the data engine a bit in version 0.5.
Are you using the default settings? Which service provider did you use? And how did you measure the memory it consumes?
When I start the applet and the data engine with plasmoidviewer, it uses 10MB. Maybe it helps to find out what causes your problems with the applet, if you send me the output of the command "plasmoidviewer publictransport" (and setting it up as you did previously. Start plasmoidviewer from a terminal).
Thanks. - Jul 17 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

>> I am using the Gentoo Ebuild (as I have created it ;) )
Ah, right ;)

I will fix the CMakeLists.txt. I installed the icons manually and forgot to modify the CMakeLists.. Thanks!

The icon for RegionalBahn is missing. - Jul 13 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Yes, it's not always /usr/share/icons. But for me it is (using openSuse) ;)
The paths to install icons, applet and data engine come from cmake. For example there's a variable KDE4_ICON_INSTALL_DIR. If you install the icons from the source archive using cmake, it should install them to the correct directory. For you that should be /usr/kde/4.2/share/icons/oxygen/. Did you install them this way?
Or did you install them with the gentoo ebuild, that installed the icons to the correct(?) directory, but then not all icons were shown in the plasmoid? - Jul 13 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Have you tried the service provider "Germany (db.de)"? It should work for all cities and stops in germany.
I can add support for kvb.de, if there's something that works better with this one than with db.de.
Thanks - Jul 13 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

For me it shows all icons properly. I haven't reinstalled the icons some time because they didn't change, but maybe there's now a bug in the installation of the icons.. The vehicle type icons should be in /usr/share/icons/oxygen/16x16/apps/vehicle_type_*.png.
If you use the sources please reinstall the icons (in the directory "publictransport-icons" in the source archive) and check if that works.
If you use one of the packages for installation, please tell me what package you are using.
Thanks - Jul 13 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The little "Configure" button is shown when the applet says that it needs to be configured. On the desktop it looks good, but in the panel it doesn't. But that should be done in plasma..
For me everything is readable with 2 lines and even with 1 line (see new screenshots). Maybe you have some other font settings that doesn't work well with the applet. But you can now also change the font in the config dialog. I also tried to make it work better with other fonts.

You will also like the new journey search feature, I think ;) But it works only with db.de (germany) and sbb.ch (switzerland) for now. - Jul 10 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The little "Configure" button is shown when the applet says that it needs to be configured. On the desktop it looks good, but in the panel it doesn't. But that should be done in plasma..
For me everything is readable with 2 lines and even with 1 line (see new screenshots). Maybe you have some other font settings that doesn't work well with the applet. But you can now also change the font in the config dialog. I also tried to make it work better with other fonts.

You will also like the new journey search feature, I think ;) But it works only with db.de (germany) and sbb.ch (switzerland) for now. - Jul 10 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Hi,
sorry. But it should now work again with version 0.4.8 :) Something with the regular expression got wrong..
You can now also search for journeys to other stops using sbb.ch with the new version ;) The journey search isn't perfect yet but will get better soon. - Jul 10 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Hi,
thanks :)
You can use "Germany (db.de)" with all stops in Leipzig (doesn't just work for trains, also trams, buses, subways..). Just type Leipzig in the stop name field and the autocompletion should pop up. The db.de-accessor currently has the most features. - Jul 10 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The structure will be permanent, if it works good for packaging. Only the version in the directory-names will change of course. Maybe the versions won't be the same at some time (for applet and data engine), but for now I'm working on both.
Thank you for updating the ebuild :) - Jul 10 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

When they put some data in it for the other cities, it should now work ;)
And "Germany" is corrected to "Slovakia". Thanks :) - Jul 10 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Hm.. my problem with sites using ASP is that I don't know how to build the url to the departure board. Somewhere in the url there must be a place for the stop name (or stop ID). And the url must be pointing directly to the departure board.
For that site always the same url is dispalyed and trying it with adding "?ctl00$MainContentHolder$ctl01$StationInput=..." doesn't work (that's the name of the input field for the stop name). Sorry.
Maybe you know how to solve this? Would be great if you could find out how to build such an url. - Jul 04 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

You can now use the buttons to move vehicle types in the filter settings :) - Jul 04 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Sorry for the crash, I think I fixed it in version 0.4.7. Please test it again and send me a new backtrace if it still crashes (was useful :)). - Jul 04 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

Ah, ok ;) I tried to enable the buttons, but unfortunatly that didn't work, sorry. You have to double click the items (train types) to move them to the other side.
I will try to find out how to have the buttons enabled / how to use KActionSelector right. - Jun 28 2009
PublicTransport

Plasma 4 Extensions by fpuelz 813 comments

The trains not being showed for you in 0.4.4 will be filtering issues, because the tooltip wasn't using filter settings. In 0.4.5 the tooltip is also using the filter settings. Could you please check if the problem is still there in 0.4.5? You can use "plasmoidviewer publictransport" in a terminal to get debug messages. The complete url used to get the departure list will be shown there.

TGV should always be displayed.. Isn't it? Only substrings in the train names that are visualized by the vehicle type icons should be removed, like "ICE 12345" => "12345". I will rethink what substrings to remove.

Thanks for the french translation I will add it to KDE playground :) - Jun 27 2009