Image 01
profile-image

eyecreate

Kevin Whitaker
Plasma Color Schemes
Plasma Themes
Be-Shell/Bespin
Plasma 4 Widgets
Ponies Everywhere

Plasma 4 Widgets 14 comments

Score 67.3%
Dec 10 2011
I have written out instructions to maygodbeless earlier in the comments list. Try using that and see if it works. - Apr 22 2013
By default, there isn't a good way to add/remove ponies. In order to save space, I removed those options from the webpage I based the widget off of. I could add back that functionailty, but some people may want it cleaner.

Your second point comes down to knowing what this widget is and what you may be askin for. This widget is a web widget that is basically just a webpage wrapped in a widget. This makes it hard to add config options and also means the roaming "Screen" is constrained to the widget borders.(which you can resize) If you'd rather them wander your whole screen and on top your programs, you might want to try something like this:
https://github.com/myszha/qt-ponies - Mar 01 2012
I'm sorry you've had trouble installing this. The fact is I had issues installing it myself(must be a bug in the package installer or my own incompetence), so maybe my more manual instructions will help.

Extract the download to whatever folder you like(maybe downloads or desktop). Copy the contents of that folder to this location:
~/.kde/share/apps/plasma/applets

Make sure it's in it's own folder inside of applets
ex. ~/.kde/share/apps/plasma/applets/PoniesEverywhere
and that you see a .desktop file directly inside there.
Then, to be safe, run this command:
kbuildsycoca4

Hopefully it will show up to be used after that. - Feb 23 2012
Glad you took notice of this! In truth, using the webkit widget framework was me taking the easy way out since it only involved me writing a manifest file to get working (and modifiying the .html to remove extra clutter)

On transparency, not sure if I'm using the webkit widget if that is possible, but it is if using a native plasma widget. The frame is configured by the theme you are using, not widget by widget basis.

I left the stop and start buttons there just for the reasons you stated, performance. On my laptop were it sits, I sometimes have to stop it if doing lots of things at once and start it again after finished since it uses about 20% cpu for me. If there was an easy way, I'd try and turn it into a native widget to increase performance along with removing some of the rendering glitches. I haven't looked far into you code, but is it abstracted enough(or can be written if needed) to run the javascript for the logic and rendering but not onto a webpage, but drawing calls able to be taken to a different canvas? If so, I can whip up a better version of this widget.

None the less, I will make an update to the new Browser Ponies version. - Dec 10 2011
Sorry, I should have mentioned you need the plasma-scriptengine-webkit package.(at least what it's called in (k)ubuntu)
This is the same engine used to run the Mac osx dashboard widgets. - Sep 24 2011
Dash

Plasma Themes 6 comments

Score 68.0%
Oct 29 2011
Since it's the same theme but modified, you may have to log out or restart. If it's still the same then, let me know but I zipped it straight out of my .kde folder. - Oct 30 2011
No problem, I actually post removed it after uploading this because it was too much for my eyes. :)

- Oct 29 2011
Rainbow Dash Color Theme

Plasma Color Schemes 3 comments

Score 56.0%
Oct 28 2011
Hm..I guess the upload scheme button doesn't work properly then. Fixing. - Oct 28 2011
Kamoso

Webcam & Monitoring 101 comments

by apol
Score 78.6%
Dec 09 2010
nevermind - Sep 12 2009
okay, that was my problem too. - Sep 12 2009
Ah, well, is it possible that KDE 4.3.x is a requirement of this program? - Sep 12 2009
for me, installing kdebase4-workspace-devel hepled me go further, but I still have this:

/usr/lib/qt4/include/Qt/objectdescriptionmodel.h:26:27: error: phonon_export.h: No such file or directory
/usr/lib/qt4/include/Qt/objectdescriptionmodel.h:27:24: error: phonondefs.h: No such file or directory

but I have phonon-devel installed. - Sep 11 2009
I am having this same issue on Mandriva 2009.1 with KDE 4.2. Is it a devel package I may not have installed? - Sep 11 2009
Redshift Plasmoid

Plasma 4 Widgets
by simgunz

Score 84.8%
Apr 22 2013