Thermal Monitor

Plasma 5 Monitoring

Source (link to git-repo or to original if based on someone elses unmodified work): https://github.com/kotelnik/plasma-applet-thermal-monitor

25
Score 84.4%
Description:

Shows temperature of various available sensors including CPU, GPU (lmsensors and nvidia-smi if appliable) and HDD (using udisks2 d-bus backend).

It can also show group of temperatures in one - the highest of them.

REQUIRED DEPENDENCIES
- qt5-graphicaleffects
- e.g. package for kubuntu users: libqt5qml-graphicaleffects

HOW TO INSTALL
- Add Widgets... -> Get new widgets -> Download new plasma widgets
- find this applet and install through the first item with .plasmoid extension
Last changelog:

4 years ago

1.2.7
- plasma 5.6 / Qt 5.6 fix

1.2.6
- scaling and other minor fixes

1.2.5
- icon is not covering label anymore
- optional drop shadows

1.2.4
- fixes when hiDPI font is used

1.2.3
- showing 'OFF' when device temperature is unavailable
- theming fixes

1.2.2
- regression when not showing HDD and nvidia temperatures fixed
- config table text eliding

1.2.1
- not properly initialized sources on startup fixed

1.2
- implemented "group of sources" showing the highest temperature of chosen sources

1.1
- got rid of hddtemp & netcat dependency by using udisks2 d-bus interface (NOTE: you need to re-add your HDD sources)

1.0.3
- fixed compatibility with KF 5.12

1.0.2
- desktop placement fix
- no-resource fix + plasmoid icon by varlesh

1.0.BETA3
- added various appearance settings

1.0.BETA2
- fixed nvidia reading
- fixed hddtemp response parsing

1.0.BETA
- initial import

MadMartian

3 years ago

I'd like to try this but nothing happens when I install it as per your instructions. It just doesn't show-up in the list of widgets, so I can't add it (even though it says its installed). I have the libqt5qml-graphicaleffects package already, running Kubuntu on 16.04.

Report

billydv

3 years ago

On Gentoo, I'm having an issue where temperatures do not show until I hit reload temperature sources. Afterwards it works fine.

Report

billydv

3 years ago

Also, when using this widget for fan readings, there is no way to disable the temp circle (icon) that appears to the top right, it would be great if the program could understand the difference between a temp and a speed

Report

f1x3rr

3 years ago

Hello!
On Fedora release 23 4.5.7-200.fc23.x86_64 I can't add my nvidia gtx660 temp sensor.
I have installed nvidia driver version:358.16, but I can't find nvidia-smi binary file.
Please help.

Report

PeterKabin

3 years ago

/usr/bin/nvidia-smi

Report

PeterKabin

3 years ago

if you don't have it, install it

Report

billydv

4 years ago

Hi,
I use your monitor and it works pretty well.
I am using it for fan speeds also. Is there a way to disable the farenheit icon for fan speed usage?

Report

mcloaked

4 years ago

I am using arch linux and plasma fully up to date. A few weeks ago I found that the widget no longer loads cpu temps on login and I have to right click the widget and get it to reload the sources. I have also updated the widget, as well as using the arch aur git version and behaviour remains the same. Is it possible to fix this problem?

Report

mcloaked

4 years ago

Copying the latest individual files from the link provided above for the dev's page to the directory on my laptop at .local/share/plasma/plasmoids/org.kde.thermalMonitor/ fixes the widget and it now updates within a second or so of the desktop starting. However I don't know if the updated files for this widget have propagated to the plasmoid file for other places which depend on the developer's source. At this stage it looks like the arch aur version is not fully up to date.

Report

muzenbaher

4 years ago

Hint fo Gentoo users

Build package "kde-plasma/ksysguard" with "lm_sensors" use flag.

Report

wolfyrion

4 years ago

hi and many thanks for this wonderful plasma widget.

I have a strange problem, I am using Manjaro and the latest Plasma and the widget is not working anymore.
In order to make it work I have to remove it and add it again but on every restart it halts...

Report

C

clearmartin

4 years ago

Hi! Thanks for report. I have this problem, too. I try to repair it soon (hopefully during this week) and post a new version. So please wait for next version.

Report

9

VaporEidolon

4 years ago

I also have the same problem. Some temperature sources are "OFF" by default and a sources reload is necessary.

Report

C

clearmartin

4 years ago

I've just commited a fix on github. Please see:
https://github.com/kotelnik/plasma-applet-thermal-monitor/issues/16

I'll upload a new version on kde-apps once I have feedback from somebody that it is fixed. I think it'l be soon:)

Report

9

VaporEidolon

4 years ago

I don't know which update broke it (I'm on Archlinux), but it seems the bug is back :(

Report

9

VaporEidolon

4 years ago

Works for me! :)

Report

wolfyrion

4 years ago

btw if i press reload temperature sources it starts working again...

Report

carthage

4 years ago

I love the widget, was just wondering if it was possible to get the temp from my amd card to show up as well? I know the page says nvidia but I was unsure of how to get amd working as I checked all the temps and they didnt match up with aticonfig --odgt. If not I also saw a post showing how to set this up with psensors(http://wpitchoune.net/blog/news_experimental-ati-monitoring-support/).
Would it be possible to do something similar with this? Thanks for your time and great work!

Report

C

clearmartin

4 years ago

Hi! Sorry for my late response, I'm temporarily quite busy nowadays.

I think we can work something out. If your ATI temperatures are not available but you know the right command to fetch the temperature ("aticonfig --odgt" ?) please provide the command along with example output so I can blindly work it in the widget and give you a test version :). Thanks! And thanks for your feedback :).

Report

9

stanqaz

4 years ago

I'm having difficulty finding the version I have installed, for now I could use a hint on where to look.

If it would be possible could you add a version number to one of the settings screens?

Report

C

clearmartin

4 years ago

You are right, there is no way determining the version. I plan to add a "debug" or "about" section in settings where debug logs can be switched on and version info will be present there, too.

Report

paviluf

4 years ago

It could be great if you update the description to explain how to install the plasmoid, because it's not clear. For exemple you can say that, now we have thermal-monitor.plasmoid, Thermal Monitor can be installed from "Add widgets..." -> Get new widgets -> Download new plasma widgets. You can also say that the "compilation installation" is optionnal since it can be installed from "Add widgets...".

Report

C

clearmartin

4 years ago

Thanks! I've done it for the rest of my widgets.

Report

Cqoicebordel

4 years ago

Nice !
But for me, the text above the temperature doesn't appear, and so the plasmoid take a lot of place, but is almost empty.
Could you look into that also ?

Report

C

clearmartin

4 years ago

Hi! So even if you fill the "Alias" field while adding new resource you still cannot see the "text above temperature"? If it is the case please also ensure, you have non-zero "Alias font size" inside Appearance settings section.

Report

4 years ago

1.2.7
- plasma 5.6 / Qt 5.6 fix

1.2.6
- scaling and other minor fixes

1.2.5
- icon is not covering label anymore
- optional drop shadows

1.2.4
- fixes when hiDPI font is used

1.2.3
- showing 'OFF' when device temperature is unavailable
- theming fixes

1.2.2
- regression when not showing HDD and nvidia temperatures fixed
- config table text eliding

1.2.1
- not properly initialized sources on startup fixed

1.2
- implemented "group of sources" showing the highest temperature of chosen sources

1.1
- got rid of hddtemp & netcat dependency by using udisks2 d-bus interface (NOTE: you need to re-add your HDD sources)

1.0.3
- fixed compatibility with KF 5.12

1.0.2
- desktop placement fix
- no-resource fix + plasmoid icon by varlesh

1.0.BETA3
- added various appearance settings

1.0.BETA2
- fixed nvidia reading
- fixed hddtemp response parsing

1.0.BETA
- initial import

12345678910
313475
product-maker xratix May 09 2020 10 the best
10 the best
product-maker qazcetelic Apr 15 2020 6 okay
It's great when it works, it resets when rebooting.
product-maker azarilh Feb 14 2020 8 great
8 great The CPU and GPU themps are off and i need to update them manually the first time every time i start Latte-dock (or plasmashell). It's solved with this tweak but it would be useful to have that update here as well: https://forum.manjaro.org/t/plasma5-applet-thermal-monitor-not-showing-cpu-temperature/71587
product-maker JillSwift Feb 02 2020 9 excellent
Marvelous - and now that kernel 5.5 can get NVMe temperatures, more marvelouser.
product-maker parecs Feb 02 2020 10 the best
Great
product-maker pyjamarama Nov 28 2019 10 the best
10 the best
product-maker tomsterXx Nov 01 2019 10 the best
10 the best
product-maker ryzen0800 Sep 22 2019 8 great
Near perfect, hddtemp doesn't work with my Samsun 970 Evo.
product-maker b1tl0rd Jul 21 2019 9 excellent
9 excellent
product-maker ged Jul 01 2019 9 excellent
9 excellent
product-maker stroum Jun 15 2019 9 excellent
It needs an update. You have to "reload temperature sources" at boot to make it work, which is a sign it may deteriorate even further in the future. This widget is a "must have" and i wish KDE developers would pick it up and make it one of the default ones, since it is critical for those who have laptops.
product-maker luca-web Jun 09 2019 8 great
8 great
product-maker electron222 Jun 02 2019 10 the best
10 the best
product-maker kdemichl Mar 20 2019 3 bad
shows "off" after boot. Needs an update. Plasma 5.15.2, KDE-Framework 5.56.0, QT-Version 5.12.1
product-maker Kelpee Mar 11 2019 9 excellent
+
product-maker Nano-Ocelot Dec 31 2018 9 excellent
+I have a weird bug where I have to 'refresh sources' after logon to display cpu core group temperatures (highest temp core shown). Otherwise it remains blank. However gpu temp (single temp source) works correctly on initial widget load.
product-maker Shevchuk May 14 2018 9 excellent
product-maker poamber Dec 24 2017 9 excellent
product-maker Vavooon Nov 10 2017 9 excellent
product-maker andik92 Oct 17 2017 9 excellent
product-maker AHTOH Jul 03 2017 9 excellent
product-maker RobberPhex May 29 2017 9 excellent
product-maker RASQ Mar 07 2017 9 excellent
product-maker mirkogennari Feb 24 2017 3 bad
product-maker dmhz Feb 14 2017 9 excellent
product-maker tepca Nov 09 2016 9 excellent
product-maker dubious Nov 09 2016 9 excellent
product-maker izzzy Nov 05 2016 9 excellent
product-maker fracaburda Oct 31 2016 9 excellent
product-maker sen7 Oct 30 2016 9 excellent
product-maker gstnet Oct 09 2016 9 excellent
product-maker Jocix Sep 13 2016 9 excellent
product-maker Tavin Sep 08 2016 9 excellent
product-maker obedlink Sep 06 2016 9 excellent
product-maker Herr_Mauer Sep 03 2016 9 excellent
product-maker Psifidotos Aug 28 2016 9 excellent
product-maker sarbash Aug 26 2016 9 excellent
product-maker lebarondemerde Jul 28 2016 9 excellent
product-maker alpvonkri Jul 28 2016 9 excellent
product-maker WuSiYu Apr 23 2016 9 excellent
product-maker VaporEidolon Apr 05 2016 9 excellent
product-maker stanqaz Feb 13 2016 9 excellent
product-maker hacklov Nov 28 2015 9 excellent
product-maker likimoki Nov 16 2015 9 excellent
product-maker ElDorado Nov 10 2015 9 excellent
product-maker MirceaKitsune Oct 23 2015 9 excellent
product-maker piegope Oct 21 2015 9 excellent
product-maker Akmazik Sep 22 2015 9 excellent
product-maker e1nste1n Sep 19 2015 9 excellent
product-maker bosssas Aug 31 2015 3 bad
product-maker schnelle Aug 27 2015 9 excellent
product-maker svah4cky0 Aug 09 2015 9 excellent
product-maker lebaron Jul 12 2015 9 excellent
product-maker darthroe Jun 24 2015 9 excellent
product-maker roctheme Jun 20 2015 9 excellent
product-maker janet Jun 17 2015 9 excellent
product-maker fmdlx Jun 16 2015 9 excellent
product-maker ksolsim Jun 16 2015 9 excellent
product-maker anespor Jun 16 2015 9 excellent
product-maker Base: 4 x 5.0 Ratings
chrizdeluxe
Apr 10 2020
azarilh
Feb 14 2020
termitavee
Jan 23 2020
slm33
Nov 15 2019
brauliobo
Nov 15 2019
b1tl0rd
Jul 21 2019
lowe
Jul 05 2019
jimjimjim
Jul 02 2019
ged
Jul 01 2019
luca-web
Jun 09 2019
Kelpee
Mar 11 2019
philipvs
Dec 26 2018
Nano-Ocelot
Dec 05 2018
javiered
Sep 20 2018
floorek
Jun 03 2018
Rokin
May 15 2018
joebrashear100
Apr 25 2018
andreagobetti
Apr 24 2018
x-varlesh-x
Apr 05 2018
stanqaz
Feb 13 2016
piegope
Oct 21 2015
lebaron
Jul 15 2015
darthroe
Jun 24 2015
janet
Jun 17 2015
mareex
Jun 17 2015
Rokin
May 15 2018
x-varlesh-x
May 13 2018
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
2 Plings
0 Affiliates
Details
license
version
1.2.8
updated Sep 08 2017
added Jun 15 2015
downloads 24h
222
mediaviews 24h 0
pageviews 24h 171