Ubuntu One Dolphin Plugin

Dolphin Service Menus

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

4
Score 78.6%
Description:

Note: Ubuntu One is stopping as aservice as of June 1st this plugin will be removed at that time see here:

http://www.softwareontheside.info/2014/04/ubuntu-one-shutting-down-and-what-that.html

or here:

http://blog.canonical.com/2014/04/02/shutting-down-ubuntu-one-file-services/

for more details. It's been fun but this plugin will also be removed as of said date.



A Ubuntu One plugin for KDE's Dolphin file manager

Extract to
~/.kde/share/kde4/services/ServiceMenus/

Depends on Ruby and Ubuntu One

Run the install script
C

ShanQful

6 years ago

If its publish and copy that's the issue there may be an issue with u1sdtool or the file isn't inside a synchronized folder. Is the file within a synchronized folder eg. the UbuntuOne folder. It looks like it's in home to me which probably isn't synchronized with u1. If it still doesn't work inside a synchronized folder try running u1sdtool on the command line and tell me what you get.

Report

apoptosis

6 years ago

Yep, it's not synchronized folder. Probably it is cause of the problem. Apparently, I din't know how to use it correctly.
Thanks!

Report

C

ShanQful

6 years ago

No prob dude that's why I have to find the time to rewrite the plugin in C++ to show people what files and folders are in sync :)

Report

ronnietucker

7 years ago

After I installed this (using the handy dandy 'Download New Services' button) I right clicked on a file to publish and got the error:

Could not find the program '~/.kde/share/kde4/services/ServiceMenus/UbuntuOne/ubuntuone.rb'

It seems that the installer creates the service menu folder as 'Ubuntu One' (with a space). Even after renaming it and removing the space I still get the ubuntuone.rb error when the file is definitely there.

Any advice is much appreciated!

Report

reves121

7 years ago

I've already installed it, but, whenever I try to sincronyze a folder I get the error "Can't find sd1tool" but I can't find that package...
Which package should I install???

Report

C

ShanQful

7 years ago

You need to install ubuntu one itself. Try
sudo apt-get install ubuntuone-control-panel-qt

The menu is trying to make a call to u1sdtool which
is ubuntu ones commandline client.

Report

12345678910
10
product-maker GEO48 Dec 21 2013 9 excellent
product-maker hackan301 Mar 12 2013 9 excellent
product-maker ShaneQful Sep 06 2012 9 excellent
product-maker step-2 Aug 21 2012 9 excellent
product-maker RAIDENSUB Aug 15 2012 9 excellent
product-maker posixru Jul 02 2012 9 excellent
product-maker Contrast Jul 01 2012 9 excellent
product-maker satch Jul 01 2012 9 excellent
product-maker unikum111 Jul 01 2012 9 excellent
product-maker reves121 Jul 01 2012 9 excellent
product-maker Count: 4 Rating: 5.0
File (click to download) Version Description Downloads Date Filesize DL OCS-Install
Pling
*Needs ocs-url or ocs-store to install things
Details
license
version
Version 2.1.5
updated Apr 06 2014
added Jun 30 2012
downloads 24h
1
page views 24h 2
System Tags addon