RSS Indicator

Plasma 5 Add-Ons

Source (link to git-repo or to original if based on someone elses unmodified work): https://github.com/cute-jumper/plasma-rss-indicator

1
Score 68.0%
Description:

RSS indicator for Plasma 5

Inspired by feedindicator, this widget is tailored for Plasma 5 with better desktop integration and more consistent look-and-feel.

Features:

- Send notifications when new feed items come
- View the unread count/mark all items as read/check updates for a particular feed
- View the total unread in the panel icon
- View the details of an item when hovered by the mouse. Left click to mark the item as read and right click to view it in your favorite browser.

See https://github.com/cute-jumper/plasma-rss-indicator for more details

comonda2

1 year ago

there is an error on kubuntu:

QML dosyası yüklenirken hata: file:///home/ahmet/.local/share/plasma/plasmoids/
rss_indicator/contents/ui/
main.qml:21:37: Type CompactRepresentation unavailable
file:///home/ahmet/.local/share/plasma/
plasmoids/rss_indicator/contents/ui/
CompactRepresentation.qml:55:5: Type FullRepresentation unavailable
file:///home/ahmet/.local/share/
plasma/plasmoids/rss_indicator/contents/
ui/FullRepresentation.qml:2:1: module "QtQuick.LocalStorage" is not installed

when i delete 17. line on the file what u say
in other comments then when i
click to open plasmoid file, an error
which say "there isnt any entering with type of "service" " (
it says in turkish; i translate) comes so it doesnt work.

Report

comonda2

1 year ago

there is a error on kubuntu:

QML dosyası yüklenirken hata: file:///home/ahmet/.local/share/plasma/plasmoids/rss_indicator/contents/ui/main.qml:21:37: Type CompactRepresentation unavailable
file:///home/ahmet/.local/share/plasma/plasmoids/rss_indicator/contents/ui/CompactRepresentation.qml:55:5: Type FullRepresentation unavailable
file:///home/ahmet/.local/share/plasma/plasmoids/rss_indicator/contents/ui/FullRepresentation.qml:2:1: module "QtQuick.LocalStorage" is not installed

when i delete 17. line on the file what u say in other comments then when i click to open plasmoid file, an error which say "there isnt any entering with type of "service" " ( it says in turkish; i translate) comes so it doesnt work.

Report

9

emplate430

1 year ago

9 TY!

Report

MalteK

2 years ago

Atom support would be very good.

Report

angelo_simone

2 years ago

Hey, excellent app! Had the same issue as scaph and solved applying your solution, cutejumper. I've been trying to increase it's size without success, if you could let us now I'd be grateful. Thanks!

Report

C

cutejumper

2 years ago

Sorry for the late reply! Really busy recently. How do you use the widget? If you put it on the desktop, you should be able to resize it by pressing the left button of your mouse for some time.

Report

scaph

2 years ago

Hi,
I have the following errors:
/.local/share/plasma/plasmoids/rss_indicator/contents/ui/main.qml:21:37: Type CompactRepresentation unavailable

rss_indicator/contents/ui/CompactRepresentation.qml:55:5: Type FullRepresentation unavailable

rss_indicator/contents/ui/FullRepresentation.qml:112:23: Type RssSourceDelegate unavailable

rss_indicator/contents/ui/RssSourceDelegate.qml:17:5: Cannot assign to non-existent property "separatorVisible"

Why ?
Kubuntu 16.04 LTS 2 - KDE Plasma 5.5.5 - Qt version 5.5.1 - kernel 4.4.0-78-generic - 64-bit

Report

C

cutejumper

2 years ago

Hi, can you try to remove the 17th line in RssSourceDelegate.qml to see whether it works?

Report

scaph

2 years ago

Oh, sorry! By starting my computer, this morning, I found that it works ... Awesome !! Thank a lot for your answer :)

Report

scaph

2 years ago

Yes, I tried, but it does not change anything ...

Report

C

cutejumper

2 years ago

Hmm... I guess it is because of the incompability between different Plasma versions. Can you try to delete the 17th line in RssSourceDelegate.qml to see whether it works?

Report

C

cutejumper

2 years ago

Hmm...I guess it is because you're using an incompatible version. Can you try to delete the 17th line in RssSourceDelegate.qml to see whether it works?

Report

9

ekaradon

2 years ago

It works great! Thank you @cutejumper!

Report

aram

2 years ago

Doesn't work...

Report

C

cutejumper

2 years ago

Can you paste the errors? Sorry for the late reply but the comment system on opendesktop.org seems broken for a long time and I can finally reply to you now.

Report

3

mirkogennari

2 years ago

Errore durante il caricamento del file QML: file:///home/mirko-gennari/.local/share/plasma/plasmoids/rss_indicator/contents/ui/main.qml:22:34: Type FullRepresentation unavailable
file:///home/mirko-gennari/.local/share/plasma/plasmoids/rss_indicator/contents/ui/FullRepresentation.qml:2:1: module "QtQuick.LocalStorage" is not installed

Report

C

cutejumper

2 years ago

You need to install the localstorage module of QtQuick. This depends on your Linux distribution. Please try google your Linux distribution and QtQuick localstorage.

Report

3

mirkogennari

2 years ago

ok thank.

Report

pyrforos

2 years ago

I get
Error loading QML file: file:///home/******/.local/share/plasma/plasmoids/rss_indicator/contents/ui/main.qml:22:34: Type FullRepresentation unavailable

Report

C

cutejumper

2 years ago

How do you install the widget? What are the files under ~/.local/share/plasma/plasmoids/rss_indicator/contents/ui/?

Report

pyrforos

2 years ago

tried both ways
plasmapkg2 --install plasmoid
install from menu


CompactRepresentation.qml FullRepresentation.qml RssList.qml
config main.qml RssSourceDelegate.qml
CurrentItemHighLight.qml rssindicator.png

Report

C

cutejumper

2 years ago

Weird...You do have FullRepresentation.qml there. Any luck running plasmoidviewer -a plasmoid under the git-cloned root directory?

Report

pyrforos

2 years ago

i think its a bug... https://forum.kde.org/viewtopic.php?f=66&t=131230

I get the same error with plasmoidviewer

Report

C

cutejumper

2 years ago

Have you figured out the problem? Do you get any other errors like mirkogennari said in his comment?

Report

pyrforos

2 years ago

No ... i did not had any free time to deal with it... The error i get is the one i mentioned at the first post and i have most QtQuick libs installed...

Report

12345678910
15
product-maker emplate430 May 19 2018 9 excellent
TY!
product-maker janet Apr 03 2017 9 excellent
product-maker ekaradon Mar 11 2017 9 excellent
product-maker mirkogennari Jan 25 2017 3 bad
product-maker bunbunbunneh Jan 24 2017 9 excellent
product-maker Bugworm Jan 20 2017 9 excellent
product-maker Base: 4 x 5.0 Ratings
x-varlesh-x
Apr 05 2018
x-varlesh-x
May 13 2018
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
1 Plings
0 Affiliates
Details
license
version
0.1.6
updated Sep 01 2017
added Jan 19 2017
downloads 24h
4
pageviews 24h 10