Plasma 5 Multimedia player video youtube

Source (link to git-repo or to original if based on someone elses unmodified work): https://github.com/zanturik/plasmatube

2
7 .8
Description:

Plasmoid for viewing youtube videos on your desktop.
You should have google account to use this plasmoid.
Current version 3.0.6

Features:
* playing youtube video :)
* searching video, channels and playlist
* presets editing and sorting (settings -> youtube channels -> click and hold, than drag)
* folders for different categories of video/playlists
* number of videos for channels/playlists in search results
* pin to stay "always on top" when docked in a panel
* drag and drop youtube links to view them
* play list of video non-stop (stop at the last video)

How to use
* Add widget -> Setting -> Google Account -> do some magic -> enjoy! :)

Roadmap (when I`ll have time for a new release in future):
* a way to copy/share video url
* "recommended" videos from youtube
* preferred language for search

Troubleshooting
* Version 3.0.6 requires QT 5.14 (or higher). If you have lower QT version in your distro (or you see the message "module QtQml version 2.14 is not installed") - use 3.0.4 (or 2.8.2).
* Version 2.8.2 is the latest version using minimum of dependencies. v3.0 requires qt-webview (qml-module-qtwebview for ubuntu) and qt-localstorage (qml-module-qtquick-localstorage for ubuntu) modules (name can differ for different OS). If you don't want (couldn't) install/use these dependencies, please use v2.8.2.
* If you see the message "Your browser doesn't support any video format", but everything is working in your favorite Firefox/Chromium, please test in in Konqueror. Firefox/Chromium doesn't use qt-webkit, but Konqueror (and Plasmatube) does. So, if you are missing some configuration/modules in you Qt, Firefox/Chromium still could be able to play video. Search in Google "Konqueror html5 video %your-distro-name%" to find more detailed information about what you should do with it.
* If you see a message like "missing Qt module", "private is not supported" or "module not found", that means you have outdated version of Qt, or you don't have some qt-modules installed. Please, update your system and install all needed modules.

Don`t hesitate to leave your comments/feedback about usability/features.
Last changelog:

v3.0.6 21 hours ago

* fix deprecation notices from Qt 5.14
* fix autoplay next video
* fix automatic panel removal/showing when video starts/stops
* fix respect theme colors in configuration

C

zanturik

1 year ago

Yeah, maybe it's a good idea.
Can you confirm that you have an option "Pinned by default" in settings? If you don't have one, I'm afraid you have an old version.

Report

9

Python

1 year ago

As I suspected, the version I was using was not the current, despite, that I have clicked on the "update plasmatube" from the widget explorer ..now, it works wonders

Report

9

Python

1 year ago

Hi zanturik

Now, I can set presets for "Chabel" and "Previews"
...but how do I store a simple video like a bookmark?
...this would be very very useful

Is it possible to insert an option to disable previews, that youtube offers on the background of the display?



thank

Report

9

migzulk

1 year ago

9 +Great!

Report

9

Python

1 year ago

Congratulations for the excellent work that you have done !!!

I consider PlasmaTube really handy to keep handy, playlists broken down by activity ...

I allow myself to suggest something if possible ...

it would be very convenient to keep in the same view of the presets, three distinct groups of presets es.

Playlists TopRated MostRecent

and maybe have the possibility to delete presets (playlists) directly from this page

Ciaoo Zanturikand thank you very much

Report

renzopc

1 year ago

Hi. Plasmatube window shows me this message "Your browser does not recognize any of the video formats available". I have Firefox Falkon and Konqueror and all of them normally reproduce YouTube videos. My distro is Kubuntu 18.04 with KDE 5.13. What can I do to fix Plasmatube on my laptop?

Report

C

zanturik

1 year ago

Try to install gstreamer1.0-libav

Report

9

ferchoj

2 years ago

Great updates!!! but I still can't see the youtube channels in the settings, show all blank.

Report

C

zanturik

2 years ago

Did you add some channels before? Try to search comething, than right click on "channel" or "playlist" and click "add".

Check the third screenshot to see the example.

Report

9

ferchoj

1 year ago

That worked, thank you very much.

Report

solandrew

2 years ago

Unfortunately does not work. "Your browser does not recognize any of the video formats available".
The browser plays YouTube video without any problems.
Firefox 60.2.1esr, OpenSUSE Leap 15

Report

C

zanturik

2 years ago

Please, test if your Konqueror can play YouTube video. Firefox/Chromium doesn't use qt-webkit, but Konqueror (and Plasmatube) does. So, if you are missing some configuration/modules in you Qt, Firefox/Chromium still could be able to play video.

PS: I've added "Troubleshooting" section in a description, hope it would help someone in future :)

Report

akha666

2 years ago

Perfect widget, how to Pin the widget to be on the top window?

Report

C

zanturik

2 years ago

Widget updated, Pin option added, please test and leave your feedback.

Report

DoctorEaker

2 years ago

Hey, I have a some sort of problem... so I've already installed de widget, and also synced my account... but it shows an error on the youtube player: "Your browser does not recognize any of the video formats available"... do I need to install anything else? I'm running on Arch btw... :l

Report

C

zanturik

2 years ago

well, your system should be capable of playing video, that's for sure. I'm not familiar with Arch, so I can't tell you what exactly you should do, but you can open konqueror and try to play some youtube video or try to search related issues for Arch.

Report

9

hannezzon

2 years ago

9 +

Report

reoy

2 years ago

It would be great if the plasmoid had a drag and drop function to place youtube links from other applications directly on it, or perhaps, although this would be a more complicated task, an entry to open the YouTube links by default with this plasmoid , although I think that for very obvious reasons that is not possible.

Report

C

zanturik

2 years ago

Hi.... New version of widget have this feature. Please, update and test.

PS: thanks for the idea! :)

Report

C

zanturik

2 years ago

Yeah, I'm afraid "open links" feature is impossible for now, but It's a good idea to receive links by drag and drop action. I'll think about it, thank you :)

Report

JeremiahK

2 years ago

I have a fresh install of OpenSUSE Tumbleweed 20172222 with KDE Plasma version 5.11.4. I am trying to get Plasmatube to play, but it is giving me the Youtube error "An error has occurred. Please try again later. (Playback ID: fbXSFZnVVVln002F) Learn More". Is there another package I need to install? Thanks.

Report

JeremiahK

2 years ago

Aha. I became familiar with the packman repos.

Report

C

zanturik

2 years ago

Hi... can you provide a short instruction for other OpenSUSE users to help them solve this problem?

Report

Warmuser

3 years ago

Beautiful Idea! But I had some difficoulty to close the widget. Please, can you add a setting to keep visible the lateral bar for dragging and closing porpouse? I want to ask you also If you are interested to add a setting to transform the video into a audio player for the desktop. Anyway, thanks! :)

Report

9

ferchoj

3 years ago

Hi Zanturik, this is a great widget, but can you put a pin option? So we can watch videos while doing other things.

Report

v3.0.6 21 hours ago

* fix deprecation notices from Qt 5.14
* fix autoplay next video
* fix automatic panel removal/showing when video starts/stops
* fix respect theme colors in configuration

v3.0.4 5 months ago

* Click on suggested videos from YouTube adds it to video list.

v3.0.2 11 months ago

* Google authentication moved to required Google flow. User should copy-paste URL and than enter code.

v3.0.0 11 months ago

* use qt-webview to avoid reloading Youtube player each time (improved performance + bug with lot of volume indicators disappeared)
* presets/folders moved to SQLite DB, improved folder management

v2.8.2 1 year ago

* Added "Folders" to bookmarks

v2.8 1 year ago

* Added "About" tab in settings with version number
* Video information moved to top of widget (on hover)
* Preset list is scrolable now

v2.6 2 years ago

* added remove video from list
* added clear list of video
* added "Search" button ( just for mouse lovers :) )
* added "Play non-stop" setting
* added "Number of loaded videos" setting.

v2.4 2 years ago

* added pin option
* added receive drag and drop youtube links

v2.2 4 years ago

* presets now contains playlist
* presets now sortable
* adding videos to presets moved from setting to main window
* different presets for different activities

v.2.1 2 years ago

* font/button colors now taken from the current theme
* playlist/channels now back in search results showing the list of videos after click
* number of videos in playlist in settings

v2.0 4 years ago

* switched Google Api key to google 0Auth
* customizable channels

v1.3 4 years ago

* Settings - added "autoplay" option
* Preset videos now sorted by date (newest the first)
* Removed unclickable links ("similar video") when video ends

v1.2 4 years ago

Bugfixes:
* search requests return only videos, not playlist.
* minimum requirements is set to QtQuick 2.0

v1.0 4 years ago

Initial release.

12345678910
62
product-maker benchile Apr 30 2020 10 the best
10 the best Your 3.04 update is working a 100% cool Have a look here please. https://i.imgur.com/6akUFGq.png
product-maker jedziemyjedziemy Mar 29 2020 10 the best
10 the best
product-maker migzulk Nov 25 2018 9 excellent
+Great!
product-maker hannezzon Jun 03 2018 9 excellent
+
product-maker ferchoj Oct 27 2017 9 excellent
product-maker aleixpol Jul 17 2017 9 excellent
product-maker Python Oct 07 2016 9 excellent
product-maker arun94 Aug 18 2016 9 excellent
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
ferchoj
Sep 16 2019
zyrox
Oct 03 2018
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
LGPLv2
version
3.0.6
updated 21 hours ago
added Aug 16 2016
downloads 24h
27
mediaviews 24h 0
pageviews 24h 141