Xt7-player (now xt7-player-mpv)

Video Players

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

6
Score 76.7%
Description:

This version is unsupported.
Xt7 also switched from mplayer to mpv.
http://qt-apps.org/content/show.php?content=151684
https://github.com/kokoko3k/xt7-player-mpv/releases

Adenilson

8 years ago

I've done everything that you said.
This ask to a program called gambas3-gb-form (
Maybe is a bug here.
dpkg: dependency problems prevent configuration of xt7-player:
xt7-player depends on gambas3-gb-form (<<2.99.90) but:
Version gambas3-gb-form system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-desktop (<<2.99.90) but:
Version gambas3-gb-desktop system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-settings (<<2.99.90) but:
Version gambas3-gb-settings in the system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-form-mdi (<<2.99.90) but:
Version gambas3-gb-form-mdi system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-web (<<2.99.90) but:
Version gambas3-gb-web system is 3.0.0 ~ oneiric1.
xt7-player depends on xbindkeys, but:
Xbindkeys package is not installed.
xt7 depends on player-youtube-dl, but:
Youtube-dl package is not installed.
dpkg: error processing xt7-player (- install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding / usr / share / applications / bamf.index ...
Errors were encountered while processing:
xt7-player
RESULT = 1

About the player:
In the kaffeine we have the function Play next/add to queue.
You could put this function to work in your player.
You certainly will get me to use your player.
About the git repo I've done this but the commands doesn't work.
So I've downloaded the latest version in .deb package.
I've installed whit kpackage that ignores dependencies but show the dependencies error above.
It seems like if the gambas3 is not the pack to this.It asks to <<gambas3 2.99.90

Report

C

koko2k

8 years ago

I installed kaffeine 1.2 and i cannot find that function. Did they removed it?
If you could explain me what exactly it did, i could consider to implement.
Meanwhile you can add every media from the browse and library tab into the playlist, which is a sort of... queue.
Is this enough?

Report

Adenilson

8 years ago

I have installed the version 0.8.8 of Kaffeine from debian and it work's fine here in my ubuntu oineric.
Install and you will see the function.
First of all remove the new Kaffeine.

Report

Adenilson

8 years ago

The new kaffeine is pure trash.
I would like that your player turn in the better way to see and listen files.
I've searched for, and the only one that gives me pleasure to use now in the new ubuntu is your player.
But the idea that I've said to you is only a suggestion.
It works fine.

Report

C

koko2k

8 years ago

I understood what you mean,
but unfortunately, even if it could seems an easy task, doing such a thing requires a deep change to the player code.

That said, is true that xt7 is currently quite dumb when it has to choose what is the next media to play, this leaves room for improvement and i'll take your suggestion into account when i'll touch the relevant code, but it won't be anytime soon.

Thanks for the idea!

Report

Adenilson

8 years ago

Here is the link to the screenshot with the function that I've said above.
http://www.4shared.com/photo/cN1JXRHS/queue.html

Report

C

koko2k

8 years ago

What command doesn't work?
You have to install git to grab the sources and you have to install gambas (3 or >2.99.6) to make the binary.

Report

Adenilson

8 years ago

I have the latest version of gambas3 and the repo to this.And the launchpad repo too.
It is installed, but the program asks to gambas 2.99.90.
The xt7 works, but in the installation says that the dependencies are not satisfied.
I'll try to install from the git repo and say to you if it works.
The player opens normally.
But appears in console that the gambas3-gb-form isn't the version to this.
Try to install in your pc using the oineric .deb version and you will see what I'm sayng.
Send me a link to download the gambas3 2.99.90.
I hope you help me.
I liked your player.
Good job.

Report

C

koko2k

8 years ago

Old version are gone, sorry.
Honestly, i don't use *ubuntu, but i tested xt7 with gambas 3.0 and it works, so it is just a matter of names that still don't matches.

You may want to take a look here:
https://bugs.launchpad.net/xt7-player/+bug/910554

...But as far as i understood from your writings, you can safely ignore that warning messages in console.

Report

Adenilson

8 years ago

I've done everything that you said.
This ask to a program called gambas3-gb-form (
Maybe is a bug here.
dpkg: dependency problems prevent configuration of xt7-player:
xt7-player depends on gambas3-gb-form (<<2.99.90) but:
Version gambas3-gb-form system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-desktop (<<2.99.90) but:
Version gambas3-gb-desktop system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-settings (<<2.99.90) but:
Version gambas3-gb-settings in the system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-form-mdi (<<2.99.90) but:
Version gambas3-gb-form-mdi system is 3.0.0 ~ oneiric1.
xt7-player depends on gambas3-gb-web (<<2.99.90) but:
Version gambas3-gb-web system is 3.0.0 ~ oneiric1.
xt7-player depends on xbindkeys, but:
Xbindkeys package is not installed.
xt7 depends on player-youtube-dl, but:
Youtube-dl package is not installed.
dpkg: error processing xt7-player (- install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding / usr / share / applications / bamf.index ...
Errors were encountered while processing:
xt7-player
RESULT = 1

About the player:
In the kaffeine we have the function Play next/add to queue.
You could put this function to work in your player.
You certainly will get me to use your player.
About the git repo I've done this but the commands doesn't work.
So I've downloaded the latest version in .deb package.
I've installed whit kpackage that ignores dependencies but show the dependencies error above.
It seems like if the gambas3 is not the pack to this.It asks to <<gambas3 2.99.90

Report

peter2m

8 years ago

Would be nice to have following things:
1. Recently opened files (in File menu)
2. Save movie time position during closing application and seek to saved time when the same movie (in the same location) is started (-ss option).
3. Subtitles under the movie.
I obtain it by following settings in mplayer config file:
vf=pp,expand=:::::1.6
It works only for vo=xv,x11

Things that not work:
1. Polish subtitles
In "Subtitles and osd" I checked "Charset" and set FallBack to cp1250 (Language is empty). Polish character are not visible (I see '?' instead them). When I call mplayer like this: Quote:mplayer moviename.avi -subcp cp1250 then Polish character are visible. In "Language" comboBox I can't find 'pl'. Thats why I not set language.
Settings Quote:-subcp 1250 in 'Windows/General options/misc/Additional option' doesn't work. Charset in 'Subtitles and osd' is unchecked. xt7-player log following command:
Quote:FMain.GetOptionsFromGui.1443: Exception, doing SubAndOsd.Init() now...
-vf-pre scale -ass -ass-force-style FontName="Bitstream Vera Sans",FontSize=18,Bold=1,Italic=Alignment=2,outline=1,OutlineColour=H00000000,MarginV=10,PrimaryColour=H00FFFFFF,shadow=2,BackColour=H7F000000 -sub-fuzziness 0 -subfont-osd-scale 4 -subfont-text-scale 4 -subpos 10 -subcp 1250 -dvbin card=1 -dvbin timeout=10 -cdrom-device "Please, choose" -vf-add eq2,hue,screenshot,scale
MplayerClass.do_play.539: commandline=mplayer -identify -slave -wid 88080784 -noconfig all -mouse-movements -vf-pre scale -ass -ass-force-style FontName="Bitstream Vera Sans",FontSize=18,Bold=1,Italic=Alignment=2,outline=1,OutlineColour=H00000000,MarginV=10,PrimaryColour=H00FFFFFF,shadow=2,BackColour=H7F000000 -sub-fuzziness 0 -subfont-osd-scale 4 -subfont-text-scale 4 -subpos 10 -subcp 1250 -dvbin card=1 -dvbin timeout=10 -cdrom-device "Please, choose" -vf-add eq2,hue,screenshot,scale -vo xv,gl,gl2,x11,null, -ao oss:/dev/dsp:/dev/mixer,alsa,arts,esd:localhost,jack,pulse::,null, -alang "en,eng" -slang "en,eng" -input conf=/tmp/FakeInput.conf:file=/home/piotr/.config/gambas3/Xt7-Player/.InputPipes/Xt7Input-37402 "moviename.avi"
Maybe some option override '-subcp 1250'?

Report

C

koko2k

8 years ago

I will implement recently opened files in the next version, have to think about the saving/restoring the movie time (i never had that need)

But about the subtitles under the movie,
think that Xt7 is meant to be a simple gui to almost all mplayer options, not a wrapper (like smplayer).
expand filter is also supported out of the box, so you can just setup a filter chain by dragging expand into the center column and set it to display subtitles.

About the polish subtitles, i certanly omitted to add pl to the combo in "sub and osd" form, and i will do, but why subcp is ignored while works for you with plain mplayer is probably an xt7 bug.
Could you please upload somwhere a little clip showing the problem so that i can reproduce and fix?

If you wish, there's a bug reporting page here, more comfortable than this site.
http://xt7-player.sourceforge.net/xt7forum/viewforum.php?f=3

Report

peter2m

8 years ago

Option "Saving/restoring the movie time" is useful when you have to or want to pause movie and turn off application in order watching movie later.

"Subtitles under the movie". I tried use "Video/Audio chains". Unfortunately it doesn't work and crashes application. I made request on bugtraq: http://xt7-player.sourceforge.net/xt7forum/viewtopic.php?f=3&t=148

"Polish subtitles" problem I resolved. There was a little bug in my additional option. I wrote: -subcp 1250 instead -subcp cp1250

Report

9

symbianflo

8 years ago

woww WIP for mdv
PS:
release a tradimento ghghghghgh zitto, zitto ,aum, aum,ma io nn ti mollo :D

Report

acidrums4

8 years ago

When will you upload the ebuild for it in the stable tree? When will be an ebuild for gambas? I'm still waiting for use this app...

Report

C

koko2k

8 years ago

I don't use gentoo anymore by years, ebuild EAPI must have been changed somehow, so i don't think i ever will, sorry.

Report

9

symbianflo

8 years ago

"Gambas 2.99.5 strictly required "
miii...ma mi vuoi coppare ???
Sappi che ti ho voluto bene ghghghgh

Report

C

koko2k

8 years ago

It is a matter of gambas being in alpha and sometimes changes symbols/names, sorry ^_^

Report

9

symbianflo

8 years ago

Wrote: /home/symbianflo/rpmbuild/SRPMS/xt7-player-2.9.1007-69.src.rpm
Wrote: /home/symbianflo/rpmbuild/RPMS/noarch/xt7-player-2.9.1007-69-mrb2011.0.noarch.rpm

Report

9

YAFU

8 years ago

You may need to specify that to use the Xt7-player3 PPA in Natty, you must also add the following Gambas 3 PPA:
https://launchpad.net/~ihaywood3/+archive/gambas3

Before to do that, you need uninstall any package related to Gambas 2, otherwise we get errors when installing packages Gambas 3.
Also I think taht in the Xt7-player3 .deb package from PPA, missing package "gambas3-gb-form-stock" as requirement wich is necessary.
Thanks!

Report

C

koko2k

8 years ago

Ok,
added another download link for gambas3 and adviced to remove gambas2 first.
Going to report the missing dep to eloaders, thanks!

Report

9

symbianflo

9 years ago

Still here , following you ... :D

( grazie mille lo amo ...)

Report

9

symbianflo

9 years ago

I'll try this weekend to port gambas3 in mandriva 2010.2 and then xt7-player3 to , keep in touch

Report

C

koko2k

9 years ago

Thanks symbianflo, I hope you succeed!

Report

9

symbianflo

9 years ago

Scritto: /home/symbianflo/rpmbuild/SRPMS/xt7-player-2.9.917-69.1mrb2010.2.src.rpm
Scritto: /home/symbianflo/rpmbuild/RPMS/noarch/xt7-player-2.9.917-69.1mrb2010.2.noarch.rpm
***************************************

Is not the point if i succeed or not , but do I have time enough .... :D
Ok done deal , gambas3 and xt7-player available on MRB ( see my signature ) and the commands to install you can find them on my post here.
http://www.mandrivausers.ro/content/gambas3-ide-complect-si-xt7-player3

Pay attention on your architecture , not for xt7-player :D but for gambas3 IDE.
Builds available only for mandriva 2010.2 32/64 bit
IMHO the most complete GUI for mplayer.
PS:
Grazie mille sei sempre il migliore ...
vedrò che posso fare su suse , se magari hanno gia le gambas3 lo macino...

Report

12345678910
8
product-maker symbianflo Mar 28 2012 9 excellent
product-maker Musikolo Nov 09 2011 9 excellent
product-maker victorcifuentes Nov 09 2011 9 excellent
product-maker aspotashev Sep 03 2011 9 excellent
product-maker tcat Jul 17 2011 9 excellent
product-maker gohanz Jun 28 2011 9 excellent
product-maker Znurre May 10 2011 9 excellent
product-maker YAFU Apr 15 2011 9 excellent
product-maker Base: 4 x 5.0 Ratings
Adenilson
Jan 07 2012
victorcifuentes
Nov 09 2011
aspotashev
Sep 03 2011
tcat
Jul 17 2011
symbianflo
Jun 29 2011
YAFU
Apr 15 2011
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
GPLv2 or later
version
git
updated Mar 13 2015
added Apr 15 2011
downloads 24h
0
mediaviews 24h 0
pageviews 24h 2