Super Karamba Sound Mixer

Karamba & Superkaramba

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5 .0
Description:

This is a Sound mixer for super karamba that hides off to the right side of the screen.
Patching Super Karamba is no longer required just install Super Karamba version 0.29
Last changelog:

17 years ago

Version 1.1 better mute function
Version 1.1 no more path changes

babofish

16 years ago

The theme would be very useful to me, if it wasent insane. i know its sopsed to move, but i dont know how to get it move right, it starts in the bottom right of my screen so i try to move it to the edge but when i let go it jumps all the back to where it was, then when i hover over it it goes further to the left.

it almost seems like its set for a special resolution and dosent want to to be changed.

maybe if you could make it work at higher rezes..

Report

C

sick

16 years ago

well actually I worte it specifically for 1280 x 1024 the resolution I use. I'll have to update so that it takes advantage of newer features. When, I do this update I'll fix this issue.

Collin

Report

ageitgey

17 years ago

The patch required to use this theme will be included in SuperKaramba 0.29 and higher as soon as it is released.

Report

C

sick

17 years ago

Tahnk you, and I consider it an honor to have the creator of the Super portion of SuperKaramba post here.

Collin

Report

Eltito

17 years ago

I downloaded the 0.26 source version of Superkaramba, when I applied the patch, the terminal gives me the answer "patch: **** Only garbage was found in the patch input.". I don't know if the patch is right applied or not.
Superkaramba compiles OK but when I start it, the program gives me the same error message. I suppose the patch works fine but I don't apply correctly.
would somebody help me?
Thanks.

Report

C

sick

17 years ago

I'm sorry I don't know much about patches this is the first time that I've used one, but I'll try and help.

1)Did you double check that you type the correct paths to the source and to the patch.

2)Try using "man patch" to learn how to patch a directory.

Again, I'm sorry that I could not be of much help.

Sincerly,
Collin

Report

Eltito

17 years ago

Hello.
I copied the text you post and paste it in a terminal, and was so careful modifying the paths. But nothing at all. I have tried it in so many ways, getting the same result.
The patch works, I know that. I'm doing something wrong, I know that too, but don't know what it is.

Report

C

sick

17 years ago

I hope this helps.

1)From a terminal TYPE cd /*/superkaramba-0.26/src
replace * with your path

2)From the same terminal TYPE
patch -i /*/bar_func/bar_functions.patch
replace * with your path

Sincerly,
Collin

Report

ushohet

17 years ago

I'm using superkaramba 0.28. When I tried your theme I got these messages:
superkaramba: TaskManager::TaskManager()
Loaded my python extension!
kdeui (KRootPixmap): [../../kdelibs/kdeui/krootpixmap.cpp:205] activating background exports.
Traceback (most recent call last):
File "skmix.py", line 58, in widgetUpdated
volBar = karamba.createBar(widget, 35, 70, 12, 100, "pics/mixer_bar.png")
AttributeError: 'module' object has no attribute 'createBar'
Call to widgetUpdated failed

Thanks
Uri

Report

C

sick

17 years ago

Yeah I'm sorry about that I forgot to mention that the SuperKaramba Sound Mixer requires that you install SuperKaramba via Source code. You will also need to use this pacth http://koti.mbnet.fi/damu/bar_functions.tar.gz to patch the source code before installing the source code. when you're ready to patch the files TYPE "patch bar_functions.patch /superkaramba-0.26/src/bar.cpp". I guess you will have to use version 0.26.

Report

C

sick

17 years ago

Yeah I'm sorry about that I forgot to mention that the SuperKaramba Sound Mixer requires that you install SuperKaramba via Source code. You will also need to use this pacth http://koti.mbnet.fi/damu/bar_functions.tar.gz to patch the source code before installing the source code. when you're ready to patch the files TYPE "patch bar_functions.patch /superkaramba-0.26/src/bar.cpp". I guess you will have to use version 0.26.

Report

17 years ago

Version 1.1 better mute function
Version 1.1 no more path changes

12345678910
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
updated Aug 01 2003
added Jun 25 2003
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0