Kopete Emoticons Manager

Various KDE 1.-4. Improvements

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
Score 50.0%
Description:

This is a patch that include an emoticons theme manager into kopete so you can add edit and remove emoticons, you can also add custom emoticons that you receive during a chat by right clicking it

i've also used part of the code of the patch founded here http://rockman.altervista.org/?p=patches.php

in order to apply the patch you have to download kopete svn http://kopete.kde.org/svnaccess.php
and then from kopete directory something like .../kdenetwork/kopete you have to do "patch -p0 < /path/to/kopete.patch"

if you get errors like
undefined reference to `EmoticonsEditDialog::EmoticonsEditDialog(QWidget*, QString, char const*)'

try to to do make -f Makefile.cvs
Last changelog:

13 years ago

- Rewritten to use qdom instead of regexp, it should works much better!

5er

13 years ago

Maybe there's difference between msn and windows live messenger.

Report

gecko

13 years ago

I like the idea, but i don't want to recompile my kopete.
The kdeartwork-emoticons package is also not directly related to kopete. I would like to have a emoticonmanager in kontrollcenter or standalone.
(I also use the same emoticons in konversation.)

Report

C

LeeSieLung

13 years ago

ok i'll try :D

Report

MilchFlasche

12 years ago

Yeah this would be REALLY great~

Report

avion

13 years ago

I'm having problem compiling it on gentooo.. everything goes well, from patching to this step..
...

make[5]: Entering directory `/var/tmp/portage/kde-base/kopete-3.5.7/work/kopete-3.5.7/kopete/kopete/config/appearance'
make[5]: *** No rule to make target `emoticonseditwidget.ui', needed by `emoticonseditwidget.h'. Stop.
make[5]: Leaving directory `/var/tmp/portage/kde-base/kopete-3.5.7/work/kopete-3.5.7/kopete/kopete/config/appearance'
make[4]: *** [all-recursive] Error 1
m
...

I looked at the makefile but it seems ok , any idea ?

Report

C

LeeSieLung

13 years ago

i've fixed the patch, now it should work

Report

DanaKil

13 years ago

when I apply the patch, I have an error :
# patch unexpectedly ends in middle of line
# Hunk #1 succeeded at 131 with fuzz 1.

any idea ?

Report

C

LeeSieLung

13 years ago

it's not a problem the patch should be applied correctly, i'll made a cleaner patch later

Report

5er

13 years ago

Why don't you also upload patched files?
That would save me a lot of trouble.
Thanks.

Report

marseillai

13 years ago

Works fine now! :) thanks for your apps! ready for kubuntu inclusion. :)

Report

5er

13 years ago

can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: kopete/config/appearance/appearanceconfig_emoticons.ui
|===================================================================
|--- kopete/config/appearance/appearanceconfig_emoticons.ui (revisione 668289)
|+++ kopete/config/appearance/appearanceconfig_emoticons.ui (copia locale)
--------------------------
File to patch:

Report

5er

13 years ago

there are no files this is trying to patch.

Someone help me

Report

C

LeeSieLung

13 years ago

try to patch with -p0 instead of -p1

Report

5er

13 years ago

There is no edit button, and there is no appearanceconfig file.

Report

5er

13 years ago

Oh, I found the problem. I ran this from ..kdenetwork/kopete, but I should run it from kdenetwork.

Report

5er

13 years ago

nope, I was wrong, that doesn't fix anything, sorry for wasting space :$

Report

5er

13 years ago

I figured out that I had to edit the kopete source and then compile.
From the emoticons editor, add, edit, remove buttons don't do anything.

Report

5er

13 years ago

Where exactly is the kopete directory, I have to use?

Report

jazztyle

13 years ago

the patch does apply on 3.5.7, but the compilation breaks with this error:

Quote:/bin/sh ../../../../libtool --silent --tag=CXX --mode=link g++ -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -march=i686 -pipe -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o kcm_kopete_appearanceconfig.la -rpath /opt/kde/lib/kde3 -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -avoid-version -module -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -R /opt/kde/lib -R /opt/kde/lib -R /opt/qt/lib -L/opt/kde/lib -L/opt/qt/lib kcm_kopete_appearanceconfig_la.all_cpp.lo ../../../libkopete/libkopete.la ../../../kopete/chatwindow/libkopetechatwindow.la -lktexteditor -lkutils -lknewstuff
.libs/kcm_kopete_appearanceconfig_la.all_cpp.o: In function `AppearanceConfig::editSelectedEmoticonTheme()':
kcm_kopete_appearanceconfig_la.all_cpp.cpp:(.text+0xe171): undefined reference to `EmoticonsEditDialog::EmoticonsEditDialog(QWidget*, QString, char const*)'
collect2: ld returned 1 exit status

the configure line looks like this:

./configure --prefix=/opt/kde --disable-debug --disable-testbed --disable-smsgsm --disable-debug --enable-final

Report

C

LeeSieLung

13 years ago

i have just compiled the official 3.5.7 release with the same configure options and i didn't get any errors

Report

jazztyle

13 years ago

could it be that your patch interferes with these 2 patches?

kopete relading kit:
http://www.kde-apps.org/content/show.php/Kopete+Reloading+Kit?content=49765

kopete uvc webcam support:
http://www.alexandredenis.net/software/kopete-uvc/

we have no other patches applied and are also using the official 3.5.7 tarballs...

Report

C

LeeSieLung

13 years ago

i have kopete reloading kit too but not the other one, anyway i'm installing archlinux on vmware right now to test

Report

dunkelstern

13 years ago

Well i traced it down a little bit further.

Seems to be a Makefile issue.

ltmain.sh doesn't generate a emoticonseditdialog.lo and it doesn't compile emoticonseditdialog.cpp, so the symbol is missing afterwards while linking.

But I don't know how to fix it as I am no automake/libtool professional.

Report

jazztyle

13 years ago

please notice that we are not using the official kde packages from arch but the kdemod packages...

you can access the latest ones by adding this entry to your /etc/pacman.conf

[kdemod]
Server = http://kdemod.ath.cx/repo/testing/i686

after doing that you can install it with

pacman -Syu
pacman -S kdemod

more info here: http://kdemod.ath.cx/

Report

jazztyle

13 years ago

please notice that we are not using the official kde packages from arch but the kdemod packages...

you can access the latest ones by adding this entry to your /etc/pacman.conf

[kdemod]
Server = http://kdemod.ath.cx/repo/testing/i686

after doing that you can install it with

pacman -Syu
pacman -S kdemod

more info here: http://kdemod.ath.cx/

Report

13 years ago

- Rewritten to use qdom instead of regexp, it should works much better!

12345678910
product-maker Base: 4 x 5.0 Ratings
File (click to download) Version Description PackagetypeArchitecture Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.2
updated May 25 2007
added Mar 20 2007
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0