pyATImonitor

Plasma 4 Widgets

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

2
Score 80.6%
Description:

This is a simple widget for KDE SC 4.3 and above that using ATI catalyst driver to monitor core clocks, memory clocks, gpu usage and core temperature.
Make sure you have installed catalyst driver and utils (aticonfig).

How to install:

[li]Download the latest version[/li]
[li]Uninstall any previous version[/li]
$ plasmapkg -r pyATImon

[li]Run the following command in the directory where the file was placed (updated to reflect the actual filename):[/li]
$ plasmapkg -i pyATImon-0.x.xx.plasmoid

[li]The widget should now be listed in your "Add Widgets" screen[/li]

If it doesn't work:
make sure you can run aitconfig in Konsole without special privileges (like root).
Last changelog:

4 years ago

- move download file to bitbucket
- 0.9.3
major UI change. using Plasma.Signalplotter instead of Plasma.Meter. Thanks baghera.
- 0.9.2
minor UI change, make it to suit user's theme
- 0.9.1
minor UI change
- 0.9
initial release

obedlink

5 years ago

I have Kubuntu 13.10 with lastest updates + lastest catalyst beta, and the plasmoid don't work.

Report

oroble

6 years ago

KDE 4.10.3 "release 563"

Ati HD6850

Report

obedlink

6 years ago

thanks work great in Kubuntu 12.10 with Catalyst drivers installed.

Report

pcreel

8 years ago

It works with KDE 4.6.5

Report

ChemBro

8 years ago

I try to use it in KDE 4.6, but all I get is "the package pyATImon (necessary for pyATImonitor) can't be opened".

So it does not work with KDE 4.6?

Report

madzapper99

8 years ago

Hi, are you planning to add monitoring of the card fan anytime soon ? Catalyst does not seem to provide such functionality in Linux (my impression) and it would be nice to know what the fan is doing and even managing it from within the script. If you feel your app is fine without the fan bit, would you know of any other app which is capable of managing the ATI fan under Linux ?

Report

C

ryanho

8 years ago

If aticonfig can provide fan working info, I can add fan monitor to pyATImonitor. I think there is no way to monitor fan status, at least for now.

Maybe we can ask AMD to provide this function in fglrx driver? :-)

Report

madzapper99

8 years ago

Looks like fan support is provided via the rather "undocumented" --pplib-cmd parameter in aticonfig. Not sure why it is kept unofficial. Could it be just a temporary feature ?

Report

pyrforos

9 years ago

... but i really liked the previus one, with the analog meter
Is it possible to make an alternative skin?
PLEASE!

Report

Izual

9 years ago

It dosnt work in KDE 4.4.2. But in Kubuntu 9.10 with kde 4.4.2 its work but not in 10.04.

The error Message "Script Initialization Failed" appears only.

While it is perhaps only an error because it is still beta but I wanted to point it.

Report

ChemBro

9 years ago

Great work! Now it's better than before! Thanks. :-D

Report

ChemBro

9 years ago

I'm using KDE 4.4 and can't install it. Is it me (my KDE 4.4 install) or the plasmoid?

Report

C

ryanho

9 years ago

I have already tested this widget on Kubuntu 9.10 and KDE SC 4.4.0.
Please follow above install instruction.

Report

ChemBro

9 years ago

Okay, I could install it and it works.

Only downside: No picture and no "temperature-like" graph for gpu load and gpu temp. Only two bars instead (see screenshot below).

http://ubuntu-pics.de/bild/43393/pyati2_h70l5x.png

Also I'm using Aya (plasma theme) with a dark colour scheme. Is it possible to use the system colour scheme for the plasmoid? As you can see, this "ATI Radeon HD 4600 Series" looks like it should.

Report

C

ryanho

9 years ago

At pyATImonitor v0.9 the gpu load and gpu temp are using analog meter. But I change them at ver 0.9.1.

And yes, it is possible to let the widget to suit user's default theme. But I need time to solve it.

Report

ChemBro

9 years ago

Okay, thanks. :-) No more questions then.

Report

C

ryanho

9 years ago

I am not sure. I never install it on KDE SC 4.4. After KDE 4.4 was released, I tried to upgrade Kubuntu 9.10, Arch Linux, and openSUSE 11.2.
But none of them can work properly after upgrade. :(

Report

ObiWahn

10 years ago

Nice!

Report

4 years ago

- move download file to bitbucket
- 0.9.3
major UI change. using Plasma.Signalplotter instead of Plasma.Meter. Thanks baghera.
- 0.9.2
minor UI change, make it to suit user's theme
- 0.9.1
minor UI change
- 0.9
initial release

12345678910
13
product-maker Phrosztbyte Nov 10 2012 9 excellent
product-maker floner123 Aug 24 2011 9 excellent
product-maker oldpiratejon Jun 27 2011 9 excellent
product-maker winford Jun 26 2011 9 excellent
product-maker leifmg Jun 24 2011 9 excellent
product-maker meerkatmiles Jun 10 2011 9 excellent
product-maker adorbutch May 24 2011 9 excellent
product-maker xophermc May 20 2011 9 excellent
product-maker kujules Apr 03 2011 9 excellent
product-maker CSander Feb 28 2011 9 excellent
product-maker poncho Feb 23 2011 9 excellent
product-maker rodeojones Feb 11 2011 9 excellent
product-maker MustangCSA Jan 31 2011 9 excellent
product-maker Count: 4 Rating: 5.0
File (click to download) MD5SUM Version Description Downloads Date Filesize DL OCS-Install
*Needs ocs-url or ocs-store to install things
Pling
Details
license
version
0.9.3
updated Mar 12 2015
added Aug 29 2009
downloads 24h
0
page views 24h 1